AdmobUnityPlugins插件打包时出问题

AdmobUnityPlugins插件打包时出问题

正在寻找答案中,都是按照说明做的,DEMO打包出IOS时会出错,不知为何。

网上查找了一下原因,说是Unity版本的问题,于是特意在MAC中安装Unity5.3试了一下打包到Xcode,居然真的可以了。因为是用另一台苹果机上打的包,在Xcode中又卡壳了,可能跟机器有关。

搞了快一整了,终于搞定了。现在总结一下遇到的问题:

1、Unity版本要5.x以上,我测试时是5.3版本。

2、把Admob中的Banner和插屏广告ID添加进入脚本中。

2、Xcode中打包前要添加上以下Framework内容。

  • AdSupport
  • AudioToolbox
  • AVFoundation
  • CoreGraphics
  • CoreMedia
  • CoreTelephony
  • EventKit
  • EventKitUI
  • MessageUI
  • StoreKit
  • SystemConfiguration

然后打包Demo就可以了。

 

参考文章:

插件下载:https://github.com/unity-plugins/Unity-Admob#downloads-admob-unity-plugin

http://bbs.51cto.com/thread-1317983-1.html